Q. Do I need to use a specific browser to access library databases?

Answer

Our library databases can be accessed by modern popular browsers: Firefox, Chrome, Edge, and Safari. We recommend that, whatever browser you are using, you have the latest version installed. Issues can occur when using old versions of browsers.

Contact the library if you have any issues accessing a database so that we can troubleshoot your problem. 

  • Last Updated Apr 28, 2020
  • Views 15
  • Answered By Jaena Manson

FAQ Actions

Was this helpful? 0   0